1. Daremos nomes as nossa interface de rede.

Interface do link (dedicado ou ADSL).
Interface dos clientes (seu hotspot).
Interface dos clientes (seu hotspot).
Interface dos clientes (seu hotspot).
Interface dos clientes (seu hotspot).
Interface dos clientes (seu hotspot).
Interface dos clientes (seu hotspot).
Interface dos clientes (seu hotspot).
Interface dos clientes (seu hotspot).
Interface do Mk-Auth.
Interface do Proxy (SpeedR, Thunder 3.1 ~ 7.0, n!moc, etc) .

Ou copie todos de uma sá vez abaixo.

/interface set ether1 name=EthInternet
/interface set ether2 name=EthLan-00
/interface set ether3 name=EthLan-01
/interface set ether4 name=EthLan-02
/interface set ether5 name=EthLan-03
/interface set ether6 name=EthLan-04
/interface set ether7 name=EthLan-05
/interface set ether8 name=EthLan-06
/interface set ether9 name=EthLan-07
/interface set slp1 name=EthMkauth

Depois crie uma bridge

/interface bridge add fast-forward=no name=bridge1

Adicione as portas lan na bridge

/interface bridge port
add bridge=bridge1 interface=EthLan-00
add bridge=bridge1 interface=EthLan-01
add bridge=bridge1 interface=EthLan-02
add bridge=bridge1 interface=EthLan-03
add bridge=bridge1 interface=EthLan-04
add bridge=bridge1 interface=EthLan-05
add bridge=bridge1 interface=EthLan-06
add bridge=bridge1 interface=EthLan-07

 

2. Vamos identificar a RB 433 ~ 1200.

Mude para o nome de sua preferência.

3. Agora adcionaremos os IP's gateway e o DNS.

Primeiro para quem tem link dedicado colocaremos o IP e mascara (lembrando que o abaixo é apenas um exemplo) o que deve ser modificado é o address, interface e o comment conforme sua preferência e necessidade.

4. Agora nosso gateway, se o mesmo estiver errado não será possível a navegar.


5 . Agora o DNS, eu utilizo o do google se for de preferência de vocês e so mudar.


6. Agora o ip de sua rede (o que vai sair para os clientes), o IP e mascara fica a clitério.

7. Agora o IP do MK-AUTH, não deve ser mudada se alguém quiser mudar lembrem-se de mudar o html do hotspot.


8. Agora o IP do seu proxy, esse pode ser conforme o seu critério so o coloque se vocês vão utilizar o mesmo.

9. Vamos agora criar nosso hotspot.


hotspot interface: bridge1
local address off network: 192.100.0.1/20
masquerade network: no (não iremos mascara porque faremos isso na interface do link)
address pool of network: 192.100.0.2-192.100.15.254 eu mudo e coloco 192.100.0.200-192.100.15.254
select certificate: none
ip address of smtp server: 0.0.0.0
dns server: 8.8.8.8,8.8.4.4
dns name: deixe em branco ou coloque o de seu domínio caso o tenha.
name of local hotspot: admin
password for the user: coloque o de sua preferência

Pronto o seu hotspot esta criado.

10. agora colocamos o address-pool como none.

_______________________________________________________________________________________

11. Iremos agora configurar o hotspot para trabalhar com o MK-AUTH.

12. Agora vamos adicionar o Mk-Auth no walled Garden no mikrotik para que seus clientes tenham acesso a central de assinante mesmo estando com o cadastro bloqueado.

13. Agora vamos configurar o cliente NTP do seu Mikrotik para que a hora sempre esteja certa (versão RouterOS 4 e 5).

Agora para a (versão da RouterOS 6) usem essa abaixo.

14. Se estivermos no horário de verão mude apenas o final para -02:00.

15. Agora vamos configurar o cliente radius no mikrotik.

16. Pagina de corte

Pagina de corte para MK-AUTH VERSÃO 4 - BUILD 85.

Pagina de corte para MK-AUTH VERSÃO 4 - BUILD 86


Pagina de corte para MK-AUTH VERSÃO 4 - BUILD 90 - por radius






Não esqueça de marca a função abaixo em radius incoming.


17. Mensagem de manutenção do provedor.

Exemplo: Quando o sinal do link cair é de grande importância que seus cliente receba uma mensagem de manutenção na tela para isso basta adicionar as regras abaixo que eles vão receber a mensagem.
A regra por padrão fica desabilitada so sendo ativada automaticamente quando o link ficar fora.

_______________________________________________________________________________________

18. Abaixo a regra para que seja habilitada automaticamente quando o link cair.

19. Vamos agora configurar a masquerade no NA
OBS: Na regra abaixo criamos um masquerade de forma que o Mk-auth e o Proxy recebam o IP dos clientes ao invés de receberem apenas do Mikrotik.
Note que a interface usada para o masquerade é a interface da internet "
EthInternet". No caso se você usa pppoe, troque EthInternet pela sua interface pppoe.

20. Agora criaremos o dst-nat para o Proxy.

Note que diferente do padrão do Mk-auth, ao invés de redirecionar apenas uma faixa de IP, eu coloque para redirecionar em listas, incluindo também uma lista de sites IP's que não redirecionados para o proxy marcados como "sem proxy". E os endereços de origem marcados como "proxy".

21. Para definirmos quis IP's do clientes (listados como "proxy") que vão ser redirecioando para o proxy.
Na regra abaixo a definimos que toda a faixa 192.100.0.0/20 ira passar para o proxy.

22. Na lista evitamos que o site do Mk-auth seja redirecionado para o proxy, pois ele consta como sendo um endereço de destino na nossa lista de "sem Proxy". Isso é interessante, pois se você ativa o proxy, os logs de acessos ao sistema do mk-auth irão constar o IP que o acessou e não do próprio Mk-auth.

23. Agora iremos também inserir o website do proxy caso o mesmo tenha como exceção na nossa lista.

24. Criaremos o usuário "mkauth" sem traços e uma senha forte de sua escolha para o mesmo.
OBS. não confunda o secret do radius com a senha do usuário mkauth para o SSH.

25. Agora acesse o winbox e mude a senha do usuário mkauth para a de sua escolha.



Parte 2 >>